<!DOCTYPE html>
<html lang="en">
<head>

<link rel="preconnect" href="https://quantcast.mgr.consensu.org" /><link rel="preconnect" href="https://audit.quantcast.mgr.consensu.org" />
<!-- Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<!--<scr ipt async src="https://quantcast.mgr.consensu.org/choice/ef319LWA1Q2Gu/www.autoevolution.com/choice.js"></scr ipt>-->
<script async src="https://cmp.quantcast.com/choice/ef319LWA1Q2Gu/www.autoevolution.com/choice.js?tag_version=V2"></script>
<script type="text/javascript" async=true>
(function() {
var host = window.location.hostname;
var firstScript = document.getElementsByTagName('script')[0];
var uspTries = 0; var uspTriesLimit = 3;
function makeStub() {
	var TCF_LOCATOR_NAME = '__tcfapiLocator'; var queue = []; var win = window; var cmpFrame;
	function addFrame() { var doc = win.document; var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]); if (!otherCMP) { if (doc.body) { var iframe = doc.createElement('iframe'); iframe.style.cssText = 'display:none'; iframe.name = TCF_LOCATOR_NAME; doc.body.appendChild(iframe); } else { setTimeout(addFrame, 5); } } return !otherCMP; }
	function tcfAPIHandler() { var gdprApplies; var args = arguments; if (!args.length) { return queue; } else if (args[0] === 'setGdprApplies') { if (args.length > 3 && args[2] === 2 && typeof args[3] === 'boolean') { gdprApplies = args[3]; if (typeof args[2] === 'function') { args[2]('set', true); } } } else if (args[0] === 'ping') { var retr = { gdprApplies: gdprApplies, cmpLoaded: false, cmpStatus: 'stub' }; if (typeof args[2] === 'function') { args[2](retr); }} else { queue.push(args); } }
	function postMessageEventHandler(event) {var msgIsString = typeof event.data === 'string'; var json = {};try {if (msgIsString) { json = JSON.parse(event.data); } else { json = event.data; }} catch (ignore) {}var payload = json.__tcfapiCall;if (payload) {window.__tcfapi(payload.command,payload.version,function(retValue, success) {var returnMsg = { __tcfapiReturn: { returnValue: retValue, success: success, callId: payload.callId } };if (msgIsString) { returnMsg = JSON.stringify(returnMsg); }event.source.postMessage(returnMsg, '*');},payload.parameter);}}
	while (win) {try {if (win.frames[TCF_LOCATOR_NAME]) {cmpFrame = win;break;}} catch (ignore) {}if (win === window.top) {break;}win = win.parent;}
	if (!cmpFrame) { addFrame(); win.__tcfapi = tcfAPIHandler; win.addEventListener('message', postMessageEventHandler, false); }
};
makeStub();
var uspStubFunction = function() {var arg = arguments;if (typeof window.__uspapi !== uspStubFunction) {setTimeout(function() {if (typeof window.__uspapi !== 'undefined') {window.__uspapi.apply(window.__uspapi, arg);}}, 500);}};
var checkIfUspIsReady = function() {uspTries++;if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) { console.warn('USP is not accessible'); } else { clearInterval(uspInterval); }};
if (typeof window.__uspapi === 'undefined') {window.__uspapi = uspStubFunction;var uspInterval = setInterval(checkIfUspIsReady, 6000);}
})();
</script>
<!-- End Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->


<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=G-D8YEMMP5NW"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'G-D8YEMMP5NW', { 'cookie_domain': 'autoevolution.com', 'anonymize_ip': true, 'send_page_view': false });
</script>
<script>
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
ga('create', 'UA-61277-6', 'autoevolution.com');
ga('set', 'anonymizeIp', true);
ga('set', 'transport', 'beacon');
ga('send', 'pageview');</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>

<link rel="preconnect" href="https://securepubads.g.doubleclick.net/" />
<link rel="preconnect" href="https://c.amazon-adsystem.com" /><link rel="preconnect" href="https://s.amazon-adsystem.com" />
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function(){
	googletag.pubads().disableInitialLoad(); (adsbygoogle=window.adsbygoogle||[]).pauseAdRequests=1;
		window.slot_6388e0b1ddea1 = googletag.defineSlot("/1004334/AE_news_300x250_ATF_240s_2", [[300, 250]], "AE_news_300x250_ATF_240s_2__placement_6388e0b1ddea1__").addService(googletag.pubads()).setTargeting("refresh", "yes");
	window.slot_6388e0b1de0a6 = googletag.defineSlot("/1004334/AE_news_300x250_ATF_240s_2", [[300, 250]], "AE_news_300x250_ATF_240s_2__placement_6388e0b1de0a6__").addService(googletag.pubads()).setTargeting("refresh", "yes");
	window.slot_6388e0b1de8e4 = googletag.defineSlot("/1004334/AE_news_970x90_240s", [[970, 250]], "AE_news_970x90_240s__placement_6388e0b1de8e4__").addService(googletag.pubads()).setTargeting("refresh", "yes");
});

window.__scripts_initialized = 0;
window.__tcfapi('addEventListener', 2, function(tcData,success){
	window.__uspapi("getUSPData", 1, function(uspData, success) { 
		if(success == false) {
			console.log('ccpa data missing:', uspData, success);
			window.__uspapi("setUspDftData", 1, function(uspData, success) { console.log('ccpa set default data:', uspData, success); APS_GO(); });
		}
		else {
			console.log('ccpa data found:', uspData, success);
			APS_GO();
		}
	});
});

function GPT_GO(){ console.log('GPT!'); googletag.pubads().setCentering(true); googletag.pubads().enableSingleRequest(); googletag.enableServices(); googletag.pubads().refresh(); (adsbygoogle=window.adsbygoogle||[]).pauseAdRequests=0; }

function APS_GO() { 
	console.log('APS 1st!'); 
	!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
	apstag.init({ pubID:  '7db38df2-4062-4df4-9018-dcf399a364c8',  adServer: 'googletag', timeout: 2e3, gdpr: { cmpTimeout: 100 } });	
	apstag.fetchBids({slots: [ { slotName: "/1004334/AE_news_300x250_ATF_240s_2", sizes: [[300, 250]], slotID: "AE_news_300x250_ATF_240s_2__placement_6388e0b1ddea1__" }, { slotName: "/1004334/AE_news_300x250_ATF_240s_2", sizes: [[300, 250]], slotID: "AE_news_300x250_ATF_240s_2__placement_6388e0b1de0a6__" }, { slotName: "/1004334/AE_news_970x90_240s", sizes: [[970, 250]], slotID: "AE_news_970x90_240s__placement_6388e0b1de8e4__" } ], timeout: 2e3, params: { adRefresh: "0" }}, function(bids) { googletag.cmd.push(function() { apstag.setDisplayBids(); GPT_GO(); }); }); 
}
</script>

<title>Watch: Repaired McLaren 675LT, Ferrari 458 and Audi R8 Plugged as New C8 Z06 Vette Alternatives - autoevolution</title>
<meta name="robots" content="max-image-preview:large" /><meta name=supported-media content="only screen and (min-width: 640px)">
<meta name="language" content="en" /><meta http-equiv="content-type" content="text/html; charset=utf-8" /><meta name="viewport" content="width=980" />
<link rel="preconnect" href="https://s1.cdn.autoevolution.com/" />
<link rel="preconnect" href="https://www.google-analytics.com" />
<link rel="apple-touch-icon" href="https://s1.cdn.autoevolution.com/_img/favicon_512.png" /><meta name="msapplication-TileImage" content="https://s1.cdn.autoevolution.com/_img/favicon_512.png" /><link rel="mask-icon" sizes="any" href="https://s1.cdn.autoevolution.com/_img/aefavicon.svg" color="#000000" />
<link rel="icon" type="image/x-icon" href="https://s1.cdn.autoevolution.com/_img/favicon.ico?v=2016" /><link rel="shortcut icon" type="image/x-icon" href="https://s1.cdn.autoevolution.com/_img/favicon.ico?v=2016" />
<link rel="alternate" type="application/rss+xml" title="autoevolution news" href="https://www.autoevolution.com/rss/backend.xml" />
<link crossorigin rel="stylesheet" type="text/css" href="https://s1.cdn.autoevolution.com/_min/?v=437&amp;g=css">
<link rel="canonical" href="https://www.autoevolution.com/news/triad-of-youtubers-debut-new-season-in-top-gear-homage-series-called-car-trek-205331.html">
<meta name="description" content="When it comes to car enthusiast entertainment, most would be in agreement that Top Gear is among their top choices, and such is the case with this trio o...">
<meta name="keywords" content="automotive entertainment, car trek, YouTube, Top Gear, McLaren, Ferrari, Audi">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.autoevolution.com/news/triad-of-youtubers-debut-new-season-in-top-gear-homage-series-called-car-trek-205331.html">
<meta property="og:title" content="Watch: Repaired McLaren 675LT, Ferrari 458 and Audi R8 Plugged as New C8 Z06 Vette Alternatives">
<meta property="og:description" content="When it comes to car enthusiast entertainment, most would be in agreement that Top Gear is among their top choices, and such is the case with this trio o...">
<meta property="article:publisher" content="https://www.facebook.com/autoevolution">
<meta property="article:published_time" content="2022-12-01T15:58:34+0000">
<meta property="og:image" content="https://s1.cdn.autoevolution.com/images-og/news/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-205331_1.jpg">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="@_autoevolution_">
<meta property="twitter:creator" content="@_autoevolution_">
<meta name="author" content="Bogdan Bebeselea">
<meta property="og:site_name" content="autoevolution">

<!-- webfontloader -->
<link crossorigin rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/coresans/coresansn45-webfont.woff2?v=2" as="font" type="font/woff2">
<link crossorigin rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/coresans/coresansn65-webfont.woff2?v=2" as="font" type="font/woff2">
<link crossorigin rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/coresans/coresansnr47-webfont.woff2?v=2" as="font" type="font/woff2">
<link crossorigin rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/coresans/coresansnr57-webfont.woff2?v=2" as="font" type="font/woff2">
<link crossorigin rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/coresans/coresansnr67-webfont.woff2?v=2" as="font" type="font/woff2">
<link crossorigin rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/glyphutil/glyphutil_neue-webfont.woff2?v=929" as="font" type="font/woff2">
<link rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts.css?v=415" as="style" >
<script>
WebFontConfig = {
	classes: false,
	events: false,
	timeout: 2000,
	custom: {
		families: ['CoreSansN:n4,n7', 'CoreSansNRCond:n4,n5,n7', 'Glyphutil Neue'],
		urls: ['https://s1.cdn.autoevolution.com/_css/fonts.css?v=415']
	}
};
</script>
<script async src="https://s1.cdn.autoevolution.com/_js/webfont-1.6.28.js?v=1"></script>
<!-- webfontloader -->


<script type="application/ld+json">{ "@context": "http://schema.org", "@type": "Organization", "url": "https://www.autoevolution.com/", "logo": "https://www.autoevolution.com/_img/autoevolution_logo_2016_ldjs.png", "name": "autoevolution",  "sameAs" : ["https://www.youtube.com/c/autoevolutioncom", "https://www.facebook.com/autoevolution", "https://twitter.com/_autoevolution_", "https://flipboard.com/@autoevolution/autoevolution-e4m5gpaay"] }</script>
<script>window.aelangvar = 'en';</script>
</head>
<body>

<div id="topbar"><div class="container2">

<i class="fa fa-bars" id="topmenubtn"></i>
<a id="autoevolution" href="https://www.autoevolution.com/" title="autoevolution">autoevolution</a>
<div id="topmenu" style="display:none;">
<ul class="m1 clearfix">
	<li><a href="https://www.autoevolution.com/cars/" title="Car models and specifications database">Cars Database</a></li>
	<li><a href="https://www.autoevolution.com/moto/" title="Motorcycle models and specifications database">Moto Database</a></li>	
	<li><a href="https://www.autoevolution.com/cars/reviews/?sort=date" title="Car reviews">Car reviews</a></li>
	<li><a href="https://www.autoevolution.com/news/videogame-reviews/" title="Game reviews">Game reviews</a></li>
	<li><a href="https://www.autoevolution.com/news/" title="All latest news">News</a></li>
	<li><a href="https://www.autoevolution.com/spyshots/" title="Car spyshots and scoops">Spyshots</a></li>
	<li><a href="https://www.autoevolution.com/news/driven/" title="Driven cars">Driven Cars</a></li>
	<li><a href="https://www.autoevolution.com/news/space-junk/" title="Space junk">Space Junk</a></li>
	<li><a href="https://www.autoevolution.com/green/" title="Green news">Green</a></li>
	<li><a href="https://www.autoevolution.com/news/renderings/" title="Car renderings and concepts">Renderings</a></li>	
	<li class="newspaper"><a href="https://www.autoevolution.com/newspaper/" title="Newspaper">Newspaper <span></span></a></li>
</ul>
<ul class="m2 clearfix">
	<li><a href="https://www.autoevolution.com/carcompare.php" title="Compare cars">Compare Cars <i class="fa fa-car col-red fsz13"></i><i class="fa fa-car col-red fsz13 faded"></i></a></li>
	<li><a href="https://www.autoevolution.com/bac/" title="Blood Alcohol Level Calculator">BAC Calculator &nbsp;<i class="fa fa-flask col-red2"></i></a></li>
	<li><a href="https://www.autoevolution.com/editorial/" title="autoevolution editorials">Editorial</a></li>
	<li><a href="https://www.autoevolution.com/coverstory/" title="autoevolution coverstories">Coverstory</a></li>
	<li><a href="https://www.autoevolution.com/news/motorsport" title="Motorsport news">Motorsport</a></li>
	<li><a href="https://www.autoevolution.com/reviews/" title="Testdrives archive">Testdrives archive</a></li>
	<li><a href="https://www.autoevolution.com/auto-moto-shows/" title="Auto shows coverage index">Auto Shows</a></li>
	<li><a href="https://www.autoevolution.com/news/tuning/" title="Auto tuning news">Tuning</a></li>
	<li><a href="https://www.autoevolution.com/carfinder/" title="Car Finder">Car Finder</a></li>
	<li><a href="https://www.autoevolution.com/newstag/pic%20of%20the%20day/" title="Photo of the Day">Photo of the Day</a></li>
	<li class="long"><a href="https://www.autoevolution.com/auto-glossary/" title="Automotive terms and acronyms database">Glossary of automotive terms</a></li>
	<div class="clearfix"></div>
</ul>
<ul class="m3 clearfix">
	<li><a href="https://www.autoevolution.com/editors/" title="Meet the autoevolution writers and editors">Masthead</a></li>
	<li><a href="https://www.autoevolution.com/rss-channels/" title="Follow autoevolution via RSS">RSS Feeds</a></li>
</ul>
</div>

<div id="topsearch" class="xsgrad1"><form method="post" action="https://www.autoevolution.com/search.php"><input type="hidden" name="subm" value="1" />
<input type="text" name="s" value="Search here..." data-defl="Search here..." /><button type="submit" class="fa fa-search"></button>
</form></div>

<div id="rtopmenu" class="fr">
	<a href="https://www.autoevolution.com/sendtip/" title="Have a news tip? Let us know!"><i class="fa fa-tip col-white"></i></a>
	<i class="fa fa-newspaper rtm-paper col-gold posrel " title="Customize and read your newspaper">
		</i>
	<a href="https://youtube.com/c/autoevolutioncom" rel="nofollow" class="col-red"><i class="fa fa-youtube-play" title="Follow us on social media"></i></a>
	<i class="fa fa-info-circle rtm-info" title="Useful information"></i>
</div>

</div></div>

<div class="container2">
	<div id="topwhite" class="h50">
			<script>
		const prevMonthlyFeatures = ['V8', 'Sea', 'RV', 'Open Top', 'Land Rover', 'Tuning', 'Iconic Vehicles', 'American', 'Travel', 'Italian', 'Mustang', 'Space', 'Truck', 'Ford', 'Celebration', 'Chevrolet', 'Tesla', 'Porsche', 'Expedition Vehicles', 'Toyota', 'Custom Builds', 'Two-wheeler', 'Muscle Car', 'Earth', 'Harley-Davidson', 'Ferrari', 'BMW M'];		
		function eventbar_toggle() {
			if($('#event_history').html().length < 100) {
				var tmp = ''; 
				for(const i of prevMonthlyFeatures) tmp += '<a href="https://www.autoevolution.com/newstag/'+encodeURI(i == 'Harley-Davidson' ? 'HD' : i)+'+Month">'+i+' Month &nbsp;<i class="fa fa-long-arrow-right"></i></a>';
				$('#event_history').html(tmp); tmp =  null;
			}
			$('#event_history').toggle();
		}
		</script>
		<div class="eventbar">
			<a href="https://www.autoevolution.com/newstag/Celebration+Month+22/" title="autoevolution's Celebration Month (2022)">
			<b class="faded">Feature:</b> 
			&nbsp; <svg style="height: 1em; position: relative; top: 0.1em; right: 0.2em;" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 640 512"><defs><style> .fa-primary{opacity:1} .fa-secondary{opacity:.4}</style></defs><path class="fa-primary" fill="currentColor" d="M640 352V400C640 417.7 625.7 432 608 432C608 370.1 557.9 320 496 320C434.1 320 384 370.1 384 432H256C256 370.1 205.9 320 144 320C82.14 320 32 370.1 32 432C14.33 432 0 417.7 0 400V288C0 260.9 16.81 237.8 40.56 228.4L82.2 124.3C96.78 87.9 132.1 64 171.3 64H353.2C382.4 64 409.1 77.26 428.2 100L528.2 225C591.2 232.1 640 286.8 640 352V352zM327.5 114.4L199.5 194.4C193.5 198.2 190.7 205.6 192.6 212.4C194.6 219.3 200.9 224 208 224H259.7L226.3 279.8C222.5 286.1 223.5 294.2 228.8 299.4C234.1 304.6 242.2 305.5 248.5 301.6L376.5 221.6C382.5 217.8 385.4 210.5 383.4 203.6C381.4 196.7 375.1 192 368 192H316.3L349.7 136.2C353.5 129.9 352.5 121.8 347.2 116.6C341.9 111.4 333.8 110.5 327.5 114.4H327.5z"/><path class="fa-secondary" fill="currentColor" d="M347.2 116.6C352.5 121.8 353.5 129.9 349.7 136.2L316.3 192H368C375.1 192 381.4 196.7 383.4 203.6C385.4 210.5 382.5 217.8 376.5 221.6L248.5 301.6C242.2 305.5 234.1 304.6 228.8 299.4C223.5 294.2 222.5 286.1 226.3 279.8L259.7 224H208C200.9 224 194.6 219.3 192.6 212.4C190.7 205.6 193.5 198.2 199.5 194.4L327.5 114.4C333.8 110.5 341.9 111.4 347.2 116.6H347.2zM224 432C224 476.2 188.2 512 144 512C99.82 512 64 476.2 64 432C64 387.8 99.82 352 144 352C188.2 352 224 387.8 224 432zM576 432C576 476.2 540.2 512 496 512C451.8 512 416 476.2 416 432C416 387.8 451.8 352 496 352C540.2 352 576 387.8 576 432z"/></svg>
			<span class="col-red upcase">Celebration Month (2022) <i class="fa fa-long-arrow-right"></i></span>
			</a>			
			<!--
			<a href="https://www.autoevolution.com/newstag/Artemis+I?utm_source=ae_self&utm_medium=ae_eventline_desktop&utm_campaign=ae_artemis_i" title="autoevolution’s &quot;Artemis I&quot; launch live coverage">
				<b class="faded">FEATURED:</b> TO THE MOON &nbsp;
				<svg style="height: 1em; position: relative; top: 0.1em; right: 0.2em;" aria-hidden="true" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><style>.fa-secondary{opacity:.4}.fa-primary{opacity:1}</style></defs><path fill="currentColor" class="fa-primary" d="M223.7 391.9C219.7 335.1 174.6 291.3 118.4 288.2C139.8 240.3 176.8 161.6 207.2 116.7C289.1-4.07 411.1-8.142 483.9 5.275C495.6 7.414 504.6 16.43 506.7 28.06C520.1 100.9 516.1 222.9 395.3 304.8C350.6 335 272.2 370.9 223.7 391.9V391.9zM384 88C361.9 88 344 105.9 344 128C344 150.1 361.9 168 384 168C406.1 168 424 150.1 424 128C424 105.9 406.1 88 384 88z"/><path fill="currentColor" class="fa-secondary" d="M23.1 288C15.33 288 7.334 283.3 3.083 275.8C-1.168 268.2-1.014 258.1 3.487 251.5L56.26 164.7C69.31 143.2 92.64 130 117.8 130H198.6C170.1 175.9 137.9 244.5 118.5 288H23.1zM381.1 394.2C381.1 419.4 368.8 442.7 347.3 455.8L260.5 508.5C253 513 243.8 513.2 236.2 508.9C228.7 504.7 223.1 496.7 223.1 488V391.8C267.9 372.8 336.4 341.5 381.1 313.4L381.1 394.2zM166.5 470C117 519.5 .4765 511.5 .4765 511.5C.4765 511.5-7.516 394.1 41.98 345.5C76.37 311.1 132.1 311.1 166.5 345.5C200.9 379.9 200.9 435.6 166.5 470zM119.8 392.2C108.3 380.8 89.81 380.8 78.38 392.2C61.92 408.7 64.58 447.4 64.58 447.4C64.58 447.4 103.3 450.1 119.8 433.6C131.2 422.2 131.2 403.7 119.8 392.2z"/></svg>
				<span class="col-red">NASA Artemis I Launch Live Coverage &nbsp;<i class="fa fa-long-arrow-right"></i></span>				
			</a>
			-->
			<div id="eventbar_toggle" onclick="eventbar_toggle()"><i class="fa fa-caret-down"></i></div>
		</div>
		<div id="event_history"></div>
		</div>
</div>

<div id="pagewrapper">

<div class="container2" itemscope itemtype="http://schema.org/NewsArticle">
	<div class="col1width col1mg fl">
		<div class="ad300x250 ad"><div id="AE_news_300x250_ATF_240s_2__placement_6388e0b1ddea1__" style="width:100%;height:auto"></div><script>googletag.cmd.push(function(){ googletag.display("AE_news_300x250_ATF_240s_2__placement_6388e0b1ddea1__"); setInterval(function(){ googletag.pubads().refresh([window.slot_6388e0b1ddea1]); }, 90000);  });</script></div>
	
		<div id="moreonthis_inner"><div class="moreonthis bulleted mgtop_30"><div class="title titletype1">More on this:</div><a href="https://www.autoevolution.com/news/youtuber-crashes-someone-s-car-teaches-lesson-on-owning-up-to-your-mistakes-205139.html?utm_source=ae_self&utm_medium=ae_moreon&utm_campaign=ae_moreon_news_static" title="YouTuber Crashes Someone&#039;s Car, Teaches Lesson on Owning Up to Your Mistakes"><img loading="lazy" decoding="async" width="90" height="60" title="YouTuber Crashes Someone&#039;s Car, Teaches Lesson on Owning Up to Your Mistakes" alt="YouTuber Crashes Someone&#039;s Car, Teaches Lesson on Owning Up to Your Mistakes" src="https://s1.cdn.autoevolution.com/images/news/youtuber-crashes-someone-s-car-teaches-lesson-on-owning-up-to-your-mistakes-205139-3.jpg"/><span><b class="black bull">1</b> YouTuber Crashes Someone&#039;s Car, Teaches Lesson on Owning Up to Your Mistakes</span></a><a href="https://www.autoevolution.com/news/youtubers-try-brakeless-driving-because-science-needs-a-challenge-once-in-a-while-204938.html?utm_source=ae_self&utm_medium=ae_moreon&utm_campaign=ae_moreon_news_static" title="YouTubers Try Brakeless Driving Because Science Needs a Challenge Once in a While"><img loading="lazy" decoding="async" width="90" height="60" title="YouTubers Try Brakeless Driving Because Science Needs a Challenge Once in a While" alt="YouTubers Try Brakeless Driving Because Science Needs a Challenge Once in a While" src="https://s1.cdn.autoevolution.com/images/news/youtubers-try-brakeless-driving-because-science-needs-a-challenge-once-in-a-while-204938-3.jpg"/><span><b class="black bull">2</b> YouTubers Try Brakeless Driving Because Science Needs a Challenge Once in a While</span></a><a href="https://www.autoevolution.com/news/watch-ken-block-s-former-gymkhana-ford-fiesta-perform-in-the-hands-of-its-new-owner-204608.html?utm_source=ae_self&utm_medium=ae_moreon&utm_campaign=ae_moreon_news_static" title="Watch Ken Block&#039;s Former Gymkhana Ford Fiesta Perform in the Hands of a New Owner"><img loading="lazy" decoding="async" width="90" height="60" title="Watch Ken Block&#039;s Former Gymkhana Ford Fiesta Perform in the Hands of a New Owner" alt="Watch Ken Block&#039;s Former Gymkhana Ford Fiesta Perform in the Hands of a New Owner" src="https://s1.cdn.autoevolution.com/images/news/watch-ken-block-s-former-gymkhana-ford-fiesta-perform-in-the-hands-of-its-new-owner-204608-3.jpg"/><span><b class="black bull">3</b> Watch Ken Block&#039;s Former Gymkhana Ford Fiesta Perform in the Hands of a New Owner</span></a><a href="https://www.autoevolution.com/news/these-guys-made-exhaust-valves-out-of-old-soviet-coins-are-they-made-of-stalinium-204294.html?utm_source=ae_self&utm_medium=ae_moreon&utm_campaign=ae_moreon_news_static" title="These Guys Made Exhaust Valves Out of Old Soviet Coins, Are They Made of Stalinium?"><img loading="lazy" decoding="async" width="90" height="60" title="These Guys Made Exhaust Valves Out of Old Soviet Coins, Are They Made of Stalinium?" alt="These Guys Made Exhaust Valves Out of Old Soviet Coins, Are They Made of Stalinium?" src="https://s1.cdn.autoevolution.com/images/news/these-guys-made-exhaust-valves-out-of-old-soviet-coins-are-they-made-of-stalinium-204294-3.jpg"/><span><b class="black bull">4</b> These Guys Made Exhaust Valves Out of Old Soviet Coins, Are They Made of Stalinium?</span></a><a href="https://www.autoevolution.com/news/i-agree-with-regular-car-reviews-the-modern-nissan-altima-is-an-awful-car-203815.html?utm_source=ae_self&utm_medium=ae_moreon&utm_campaign=ae_moreon_news_static" title="I Agree With Regular Car Reviews, The Modern Nissan Altima is an Awful Car"><img loading="lazy" decoding="async" width="90" height="60" title="I Agree With Regular Car Reviews, The Modern Nissan Altima is an Awful Car" alt="I Agree With Regular Car Reviews, The Modern Nissan Altima is an Awful Car" src="https://s1.cdn.autoevolution.com/images/news/i-agree-with-regular-car-reviews-the-modern-nissan-altima-is-an-awful-car-203815-3.jpg"/><span><b class="black bull">5</b> I Agree With Regular Car Reviews, The Modern Nissan Altima is an Awful Car</span></a></div></div>		<div id="moreonthis_inner">
			<div class="moreonthis mgtop_20" style="min-height:214px">
				<div class="title titletype1">Car video reviews:</div>
				<div id="vrevdiv">
				<script>!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.src='javascript:false'; t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js?cid=dccd48aa-57cf-4b40-82ea-0f2e6b39a023',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);</script>
<script id="ba856d60cd2541638122490a129812ed">(new Image()).src = 'https://capi.connatix.com/tr/si?token=9dd3d7ea-7068-40c5-8d6e-0a890b23b1f9&cid=dccd48aa-57cf-4b40-82ea-0f2e6b39a023'; cnxps.cmd.push(function () { cnxps({ playerId: "9dd3d7ea-7068-40c5-8d6e-0a890b23b1f9"  }).render("ba856d60cd2541638122490a129812ed");  });</script>
				</div>
			</div>
		</div>
		<div class="ad300x250 mgtop_40"><div id="AE_news_300x250_ATF_240s_2__placement_6388e0b1de0a6__" style="width:100%;height:auto"></div><script>googletag.cmd.push(function(){ googletag.display("AE_news_300x250_ATF_240s_2__placement_6388e0b1de0a6__"); setInterval(function(){ googletag.pubads().refresh([window.slot_6388e0b1de0a6]); }, 90000);  });</script></div>
		<div id="moreonthis_inner">
						<div class="moreonthis mgtop_30">
				<div class="title titletype1 upcase"><a href="" title="Up Next">Up Next &nbsp;<i class="fa fa-long-arrow-right"></i></a></div>
				<a href="https://www.autoevolution.com/news/the-fantastic-google-maps-feature-that-almost-nobody-uses-205340.html?utm_source=ae_self&utm_medium=ae_upnext&utm_campaign=ae_upnext_left">
					<img loading="lazy" decoding="async" src="https://s1.cdn.autoevolution.com/images/news/the-fantastic-google-maps-feature-that-almost-nobody-uses-205340-3.jpeg" width="66" height="40" />
					<span>The Fantastic Google Maps Feature That Almost Nobody Uses</span>
				</a>
			</div>
					</div>

		&nbsp;
	</div>


<article id="newscol2" class="col2width">
<link itemprop="mainEntityOfPage" href="https://www.autoevolution.com/news/triad-of-youtubers-debut-new-season-in-top-gear-homage-series-called-car-trek-205331.html" />
<meta itemprop="datePublished" content="2022-12-01T15:58:34+0000" />
<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
		<meta itemprop="url" content="https://s1.cdn.autoevolution.com/_img/autoevolution_logo_2016_ldjs.png">
		<meta itemprop="width" content="500">
		<meta itemprop="height" content="100">
	</div>
	<meta itemprop="name" content="autoevolution">
</div>

<h1 itemprop="headline" class="padcol2 nomgbot newstitle innews">Repaired McLaren 675LT, Ferrari 458 and Audi R8 Plugged as New C8 Z06 Vette Alternatives</h1>

<div class="breadcrumb innews" style="height: auto !important">
<span itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><meta itemprop="position" content="1" /><a href="https://www.autoevolution.com/" itemprop="item" title="Home"><span itemprop="name">Home</span></a></span> &gt; <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><meta itemprop="position" content="2" /><a href="https://www.autoevolution.com/news/" itemprop="item" title="News"><span itemprop="name">News</span></a></span> &gt; <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><meta itemprop="position" content="3" /><a href="https://www.autoevolution.com/news/u-turn/" itemprop="item" title="U-turn"><span itemprop="name">U-turn</span></a></span></span>	<div class="dateby">
		<time datetime="2022-12-01T15:58:34+0000">1 Dec 2022, 15:58 UTC</time> &bull; 		By: <div class="col2author" itemscope itemtype="http://schema.org/Person" itemprop="author"> 
			<a href="https://www.autoevolution.com/editors/browse/bogdan-bebeselea/" title="Check out Bogdan Bebeselea's author profile" itemprop="url"><u><b itemprop="name">Bogdan Bebeselea</b></u></a>
										</div>
			</div>
	<div class="top2line5" style="clear:both"></div>
</div>


<div itemprop="articleBody">
	<div class="newssubtext">When it comes to car enthusiast entertainment, most would be in agreement that Top Gear is among their top choices, and such is the case with this trio of YouTubers. In order to pay homage to the famous TV show, they decided to launch their own series called Car Trek a couple of years ago.</div><div class="ch_pic" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><a id="xaegal_0" class="fullimg" href="https://s1.cdn.autoevolution.com/images/news/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-205331_1.jpg" target="_blank" title="Car Trek Season 9 "><picture>
<source type="image/webp" srcset="https://s1.cdn.autoevolution.com/images-webp/news/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-205331-7.jpg.webp">
<source type="image/jpeg" srcset="https://s1.cdn.autoevolution.com/images/news/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-205331-7.jpg">
<img decoding="async" itemprop="thumbnailUrl" src="https://s1.cdn.autoevolution.com/images/news/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-205331-7.jpg" data-gidx="0" data-big="https://s1.cdn.autoevolution.com/images/news/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-205331_1.jpg" data-description="Photo credits: YouTube / Tavarish " alt="Car Trek Season 9 " title="Car Trek Season 9 " data-title="Car Trek Season 9 " width="600" height="340" />
</picture></a><span><em class="fa fa-search-plus"></em> 13 photos</span><meta itemprop="url" content="https://s1.cdn.autoevolution.com/images/news/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-205331_1.jpg"><meta itemprop="width" content="1219"><meta itemprop="height" content="605"></div><div class="newsgal2 posrel"><div class="vslide" data-count="12"><a id="aegal_0" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_1.jpg" data-num="0" rel="noopener"><img title="Car Trek Season 9 Cars" alt="Car Trek Season 9 Cars" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_1.jpg" width="161" height="86" data-onload="aengal_picloaded('.newsgal',0);" data-gidx="1" data-gidm="1683240" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Car Trek Season 9 Cars" /></a><a id="aegal_1" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_2.jpg" data-num="1" rel="noopener"><img title="Car Trek Season 9 Cars" alt="Car Trek Season 9 Cars" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_2.jpg" width="173" height="86" data-onload="aengal_picloaded('.newsgal',1);" data-gidx="2" data-gidm="1683241" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Car Trek Season 9 Cars" /></a><a id="aegal_2" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_3.jpg" data-num="2" rel="noopener"><img title="Tavarish&#039;s McLaren 675LT" alt="Tavarish&#039;s McLaren 675LT" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_3.jpg" width="177" height="86" data-onload="aengal_picloaded('.newsgal',2);" data-gidx="3" data-gidm="1683242" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Tavarish&#039;s McLaren 675LT" /></a><a id="aegal_3" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_4.jpg" data-num="3" rel="noopener"><img title="Tavarish&#039;s McLaren 675LT" alt="Tavarish&#039;s McLaren 675LT" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_4.jpg" width="156" height="86" data-onload="aengal_picloaded('.newsgal',3);" data-gidx="4" data-gidm="1683243" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Tavarish&#039;s McLaren 675LT" /></a><a id="aegal_4" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_5.jpg" data-num="4" rel="noopener"><img title="Tavarish&#039;s McLaren 675LT" alt="Tavarish&#039;s McLaren 675LT" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_5.jpg" width="174" height="86" data-onload="aengal_picloaded('.newsgal',4);" data-gidx="5" data-gidm="1683244" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Tavarish&#039;s McLaren 675LT" /></a><a id="aegal_5" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_6.jpg" data-num="5" rel="noopener"><img title="Tavarish in his McLaren 675LT" alt="Tavarish in his McLaren 675LT" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_6.jpg" width="160" height="86" data-onload="aengal_picloaded('.newsgal',5);" data-gidx="6" data-gidm="1683245" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Tavarish in his McLaren 675LT" /></a><a id="aegal_6" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_7.jpg" data-num="6" rel="noopener"><img title="Tyler Hoover&#039;s Ferrari 458 Spider" alt="Tyler Hoover&#039;s Ferrari 458 Spider" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_7.jpg" width="173" height="86" data-onload="aengal_picloaded('.newsgal',6);" data-gidx="7" data-gidm="1683246" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Tyler Hoover&#039;s Ferrari 458 Spider" /></a><a id="aegal_7" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_8.jpg" data-num="7" rel="noopener"><img title="Tyler Hoover&#039;s Ferrari 458 Spider" alt="Tyler Hoover&#039;s Ferrari 458 Spider" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_8.jpg" width="175" height="86" data-onload="aengal_picloaded('.newsgal',7);" data-gidx="8" data-gidm="1683247" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Tyler Hoover&#039;s Ferrari 458 Spider" /></a><a id="aegal_8" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_9.jpg" data-num="8" rel="noopener"><img title="Ed Bolian in his Audi R8" alt="Ed Bolian in his Audi R8" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_9.jpg" width="163" height="86" data-onload="aengal_picloaded('.newsgal',8);" data-gidx="9" data-gidm="1683248" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Ed Bolian in his Audi R8" /></a><a id="aegal_9" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_10.jpg" data-num="9" rel="noopener"><img title="Ed Bolian&#039;s Audi R8" alt="Ed Bolian&#039;s Audi R8" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_10.jpg" width="175" height="86" data-onload="aengal_picloaded('.newsgal',9);" data-gidx="10" data-gidm="1683249" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Ed Bolian&#039;s Audi R8" /></a><a id="aegal_10" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_11.jpg" data-num="10" rel="noopener"><img title="Ed Bolian&#039;s Audi R8" alt="Ed Bolian&#039;s Audi R8" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_11.jpg" width="175" height="86" data-onload="aengal_picloaded('.newsgal',10);" data-gidx="11" data-gidm="1683250" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Ed Bolian&#039;s Audi R8" /></a><a id="aegal_11" href="https://s1.cdn.autoevolution.com/images/news/gallery/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek_12.jpg" data-num="11" rel="noopener"><img title="Ed Bolian&#039;s Audi R8 racing the 1JZ Toyota Corona" alt="Ed Bolian&#039;s Audi R8 racing the 1JZ Toyota Corona" decoding="async" loading="lazy" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/triad-of-youtubers-debut-new-season-in-topgear-homage-series-called-car-trek-thumbnail_12.jpg" width="176" height="86" data-onload="aengal_picloaded('.newsgal',11);" data-gidx="12" data-gidm="1683251" data-gida="205331"  data-description="Photo credits: YouTube / Tavarish" data-title="Ed Bolian&#039;s Audi R8 racing the 1JZ Toyota Corona" /></a><script type="application/ld+json" id="schema-gallery-data">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</script></div><div class="dotbox curpo" onclick="return open_lght(0)"></div></div>	<div class="newstext innews">
		<div class="mgtop_20">
			With the history out of the way, it&rsquo;s time to meet the hosts. They are Tyler Hoover, who runs the Hoovies Garage YouTube channel, Freddy Hernandez, who is known as Tavarish, and Ed Bolian, who is the man behind VINwiki. They are all entertaining in their own right but put them together and you get a slight hint of that Top Gear type of friendship. <br />
<br />
Of course, this translates into the cars each of them chose. The theme of the new series is buying wrecked and repaired exotic cars for less than the price of a new C8 Corvette. So, obviously, that was completely disregarded by two of our protagonists, which was abundantly clear when they introduced their cars at the Thunderhill raceway park.<br />
<br />
Ed brought a 2017 Audi R8 V10 that had a clean history with only minor cosmetic damage, while Freddy decided the best option was his <a rel="noopener" target="_blank" href="https://www.autoevolution.com/news/moe-shalizis-mclaren-765lt-spider-gets-a-new-grey-wrap-and-carbon-hood-202932.html">McLaren</a> 675LT, which cost a grand total of $240,000 to buy and fix. Tyler was left as the only person to respect the terms of their challenge, having brought a previously wrecked 2013 Ferrari 458 Spider that he bought for just 100 grand. <br />
<br />
Considering two of the cars were previously crashed (rather severely), they all had to be inspected before being allowed on the track. Unsurprisingly, Ed&rsquo;s Audi was in tip-top shape, while Tyler&rsquo;s Ferrari barely passed the inspection and was allowed to go and hoon about. Meanwhile, the 675LT rebuilt by Freddy himself had to stay back and have a coolant leak fixed, which obviously prompted quite a few remarks from the co-hosts. <br />
<br />
With all the cars ready, the next challenge was up. The trio would have to race Indy Pro 2000 driver Reece Gold. Despite Freddy having the most powerful car, with 666 hp (675 ps) and 516 lb. ft. (700 Nm) of torque, he crossed the finish line second against Reece&rsquo;s 1JZ-powered Toyota Corona. Tyler did not fare much better, spinning out of the race lead and losing as well. This left Ed and his <a rel="noopener" target="_blank" href="https://www.autoevolution.com/news/audi-r8-v10-goes-skiing-uphill-with-summer-tires-can-you-guess-the-outcome-202390.html">R8</a> with 610 hp (619 ps) and 413 lb. ft. (560 Nm) of torque to win against the 17-year-old, which he did. <br />
<br />
The video concludes with a top contest down the straight of the circuit between the three YouTubers, which ended in the most predictable fashion. The McLaren took first place, followed by the Audi, and the <a rel="noopener" target="_blank" href="https://www.autoevolution.com/news/binotto-leaves-ferrari-four-other-f1-teams-rumored-to-want-him-including-a-top-contender-205244.html">Ferrari</a> with its meager 562 hp (570 ps) and 398 lb. ft. (540 Nm) of torque came last.<br />
<br />
<br />
<div class="videospot" title="Click to play video">
					<a class="dispblock" href="https://youtu.be/1nF2Uo2eVDA" data-embed="https://www.youtube-nocookie.com/embed/1nF2Uo2eVDA?wmode=transparent" target="_blank" title="Click to play video">
						<img alt="Video thumbnail" data-gidx="-1" width="480" height="360" loading="lazy" decoding="async" src="https://img.youtube.com/vi/1nF2Uo2eVDA/hqdefault.jpg" />
						<span><i class="fa fa-play"></i></span>
					</a>
				</div>						<br/><br/><i class="fa fa-flag-checkered ico col-red3"></i>
			
			<div class="clearfix"></div>
		</div>
	</div>
</div>

<div>
	<div class="padcol2 mgtop_20">
		<img loading="lazy" decoding="async" class="imagegn" src="https://s1.cdn.autoevolution.com/_img/g_news.png" height="32" width="32" srcset="https://s1.cdn.autoevolution.com/_img/g_news.png, https://s1.cdn.autoevolution.com/_img/g_news_2x.png 2x" alt="Google News icon" /><a class="buttongn" href="https://news.google.com/publications/CAAiEBZaDaGr808wbz9j3xIrjtsqFAgKIhAWWg2hq_NPMG8_Y98SK47b?hl=en-US&gl=US&ceid=US:en" target="_blank" rel="nofollow" title="Follow autoevolution on Google News">Follow <strong>autoevolution</strong> on Google News</a>
	
	
		<div class="clearfix"></div>
</div>
<div class="posrel"></div><!-- posrel -->
<div class="filedunder mgtop_20"><a href="https://www.autoevolution.com/newstag/automotive%20entertainment/" title="More stories about &quot;automotive entertainment&quot;" class="newstag">automotive entertainment</a> <a href="https://www.autoevolution.com/newstag/car%20trek/" title="More stories about &quot;car trek&quot;" class="newstag">car trek</a> <a href="https://www.autoevolution.com/newstag/YouTube/" title="More stories about &quot;YouTube&quot;" class="newstag">YouTube</a> <a href="https://www.autoevolution.com/newstag/Top%20Gear/" title="More stories about &quot;Top Gear&quot;" class="newstag">Top Gear</a> <a href="https://www.autoevolution.com/newstag/McLaren/" title="More stories about &quot;McLaren&quot;" class="newstag">McLaren</a> <a href="https://www.autoevolution.com/newstag/Ferrari/" title="More stories about &quot;Ferrari&quot;" class="newstag">Ferrari</a> <a href="https://www.autoevolution.com/newstag/Audi/" title="More stories about &quot;Audi&quot;" class="newstag">Audi</a> </div>
<div class="clearfix"></div>
<div id="disqus_thread" class="bgwhite overauto"><button onclick="$('#disqus_thread').toggleClass('padcol2'); loadDisqus()" type="button" class="ulbtn dispblock posrel zx1"><i class="fa fa-comment col-red"></i>click to load Disqus comments for this story</span><span class="disclaim">This enables Disqus, Inc. to process some of your data.</span></button></div>
<script>var disqus_config = function () { this.page.url = 'https://www.autoevolution.com/news/triad-of-youtubers-debut-new-season-in-top-gear-homage-series-called-car-trek-205331.html'; this.page.identifier = 'dsq_ae_news_205331'; };</script>
<div class="clearfix"></div>



</article><!-- midcol -->

<div id="newscol3" class="col3width overhide">
<div class="moreonthis mgleft_20 nomgtop vehicles"><div class="title titletype1">Latest car models:</div><a href="https://www.autoevolution.com/cars/subaru-impreza-5-doors-2022.html" title="SUBARU Impreza 5 doors"><img loading="lazy" decoding="async" width="90" height="60" title="SUBARU Impreza 5 doors" alt="SUBARU Impreza 5 doors" src="https://s1.cdn.autoevolution.com/images/models/thumb/SUBARU_Impreza-5-doors-2022_main.jpg_tmb.jpg"/><span>SUBARU Impreza 5 doors <span>Compact</span></span></a><a href="https://www.autoevolution.com/cars/lamborghini-sterrato-2022.html" title="LAMBORGHINI Sterrato"><img loading="lazy" decoding="async" width="90" height="60" title="LAMBORGHINI Sterrato" alt="LAMBORGHINI Sterrato" src="https://s1.cdn.autoevolution.com/images/models/thumb/LAMBORGHINI_Sterrato-2022_main.jpg_tmb.jpg"/><span>LAMBORGHINI Sterrato <span>Coupe</span></span></a><a href="https://www.autoevolution.com/cars/chevrolet-impala-convertible-1959.html" title="CHEVROLET Impala Convertible"><img loading="lazy" decoding="async" width="90" height="60" title="CHEVROLET Impala Convertible" alt="CHEVROLET Impala Convertible" src="https://s1.cdn.autoevolution.com/images/models/thumb/CHEVROLET_Impala-Convertible-1959_main.jpg_tmb.jpg"/><span>CHEVROLET Impala Convertible <span>Roadster &amp; Convertible</span></span></a><a href="https://www.autoevolution.com/cars/opel-astra-gse-2022.html" title="OPEL Astra Electric"><img loading="lazy" decoding="async" width="90" height="60" title="OPEL Astra Electric" alt="OPEL Astra Electric" src="https://s1.cdn.autoevolution.com/images/models/thumb/OPEL_Astra-GSe-2022_main.jpg_tmb.jpg"/><span>OPEL Astra Electric <span>Compact</span></span></a><a href="https://www.autoevolution.com/cars/subaru-impreza-4-doors-2020.html" title="SUBARU Impreza 4 doors"><img loading="lazy" decoding="async" width="90" height="60" title="SUBARU Impreza 4 doors" alt="SUBARU Impreza 4 doors" src="https://s1.cdn.autoevolution.com/images/models/thumb/SUBARU_Impreza-4-doors-2020_main.jpg_tmb.jpg"/><span>SUBARU Impreza 4 doors <span>Compact</span></span></a><a href="https://www.autoevolution.com/cars/audi-rs6-avant-performance-2022.html" title="AUDI RS6 Avant performance"><img loading="lazy" decoding="async" width="90" height="60" title="AUDI RS6 Avant performance" alt="AUDI RS6 Avant performance" src="https://s1.cdn.autoevolution.com/images/models/thumb/AUDI_RS6-Avant-performance-2022_main.jpg_tmb.jpg"/><span>AUDI RS6 Avant performance <span>Compact</span></span></a><a href="https://www.autoevolution.com/cars/subaru-impreza-5-doors-2020.html" title="SUBARU Impreza 5 doors"><img loading="lazy" decoding="async" width="90" height="60" title="SUBARU Impreza 5 doors" alt="SUBARU Impreza 5 doors" src="https://s1.cdn.autoevolution.com/images/models/thumb/SUBARU_Impreza-5-doors-2020_main.jpg_tmb.jpg"/><span>SUBARU Impreza 5 doors <span>Compact</span></span></a><a href="https://www.autoevolution.com/cars/honda-civic-type-r-2022.html" title="HONDA Civic Type R"><img loading="lazy" decoding="async" width="90" height="60" title="HONDA Civic Type R" alt="HONDA Civic Type R" src="https://s1.cdn.autoevolution.com/images/models/thumb/HONDA_Civic-Type-R-2022_main.jpg_tmb.jpg"/><span>HONDA Civic Type R <span>Compact</span></span></a><a href="https://www.autoevolution.com/cars/ford-everest-2022.html" title="FORD Everest"><img loading="lazy" decoding="async" width="90" height="60" title="FORD Everest" alt="FORD Everest" src="https://s1.cdn.autoevolution.com/images/models/thumb/FORD_Everest-2022_main.jpg_tmb.jpg"/><span>FORD Everest <span>Medium SUV</span></span></a><a href="https://www.autoevolution.com/cars/audi-r8-gt-us-2022.html" title="AUDI R8 GT (US)"><img loading="lazy" decoding="async" width="90" height="60" title="AUDI R8 GT (US)" alt="AUDI R8 GT (US)" src="https://s1.cdn.autoevolution.com/images/models/thumb/AUDI_R8-GT--US--2022_main.jpg_tmb.jpg"/><span>AUDI R8 GT (US) <span>Exotic</span></span></a><a href="https://www.autoevolution.com/cars/" title="Full list of car models and specifications" class="bold upcase seeall">All car models &nbsp;<i class="fa fa-long-arrow-right"></i></a></div>
		<div class="mgleft_20 mgtop_20">
		<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
		<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2364887827571271" data-ad-slot="9053923839" data-ad-format="link" data-full-width-responsive="true"></ins>
		<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
	</div>
	
	
</div><!-- newscol3 -->

<div class="clearfix"></div>

<div class="col123width bgcutgrad">	<div class="ad970x250 ad ad_adc" style="background-color: #e4e4e4; text-align: center;"><div id="AE_news_970x90_240s__placement_6388e0b1de8e4__" style="width:100%;height:auto"></div><script>googletag.cmd.push(function(){ googletag.display("AE_news_970x90_240s__placement_6388e0b1de8e4__"); setInterval(function(){ googletag.pubads().refresh([window.slot_6388e0b1de8e4]); }, 90000);  });</script></div></div>
<div class="fl" id="newscol1">
	<div id="morepopular1">&nbsp;</div>
	<div id="morescrollad1">&nbsp;</div>
	<div id="morepopular2">&nbsp;</div>
</div>
<div class="col2width fl bgcutgrad" id="morescroll">&nbsp;</div>

<div class="col3width fl">
	<div id="more_X">&nbsp;</div>
	<div id="morelinks">&nbsp;</div>
</div>

<div class="clearfix"></div>
<div class="col123width bgcutgrad"><div id="morescrollad2"></div><br/></div>

</div><!-- container -->

<!--<iframe title="statistics" class="artr" src="https://www.autoevolution.com/rhh.php?k=artr&art=205331&se=news&ref=" width="0" height="0"></iframe>-->
<script async src="https://www.autoevolution.com/rhh.php?k=artr&art=205331&se=news&ref="></script>

<script>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</script>

<div id="notif_asker_div">
	<div id="notif_asker_buttons">
		<h4>Would you like <span class="col-red">AUTOEVOLUTION</span> to send you notifications?</h4>
		<p>You will only receive our top stories</p>
		<div id="notif_asker_btns">
			<button type="button" class="notif_btn blk" onclick="notif_continue(true)" title="Please click ALLOW when prompted">yes</button>
			<button type="button" class="notif_btn" onclick="notif_continue(false)">no</button>
		</div>
	</div>
</div>

<script>
function notif_asker() {
	$('body,html').css('overflow', 'hidden');
	$('#notif_asker_div').show();
}

function notif_continue(go) {
	if(go === true) {
		ae_setcookie('notif_dontask', 'dont', 60);

		$('#notif_asker_buttons').html('<h4 class="mgbot_20"><span class="col-red">Thank you!</span><br/>Please click ALLOW when prompted</h4>');
		setTimeout(function() {
			$('#notif_asker_div').remove();
			$('body,html').css('overflow', 'visible');
		}, 3000);

		var d = document, s = d.createElement('script');
		s.src = 'https://www.autoevolution.com/notificator.js?v=127';
		s.setAttribute('id', 'notif_asker_js');
		(d.head || d.body).appendChild(s);
		window.askOnLoad = 1;
	}
	else {
		ae_setcookie('notif_dontask', 'dont', 60);
		$('#notif_asker_div').remove();
		$('body,html').css('overflow', 'visible');
	}
}
</script>

<div class="clearfix"></div>
</div><!-- pagewrapper -->

<div id="footer">
	<div class="container">
		<div id="footcol1">
			<a href="/rss-channels/" class="fa fa-rss fl col-red"></a>
			<a href="https://www.autoevolution.com/" id="footauto" title="autoevolution">autoevolution</a>
			<span id="footprivacyl">
				<a href="/static/about-us.html" title="About Us">About Us</a> &bull;
				<a href="/contact/" title="Contact Us">Contact</a> &bull;				
				<a href="/editors/" title="autoevolution masthead &amp; editorial team members">Team</a>				<br/>
				California residents: <a href="javascript:;" onclick="window.__uspapi('displayUspUi');" title="Do Not Sell My Info" id="CCPA_STATUS">Do Not Sell My Info</a> &bull; <a href="/static/privacy.html#ccpa" class="underline">More Info</a>			</span>
		</div>
		<div id="footcol2">
			<ul>
							<li><a href="/cars/" title="Cars">Cars</a></li>
				<li><a href="/moto/" title="Moto">Moto</a></li>
				<li><a href="/news/" title="News">News</a></li>
				<li><a href="/cars/reviews/" title="Car Reviews">Reviews</a></li>
				<li><a href="/editorial/" title="Editorials">Editorials</a></li>
				<li><a href="/coverstory/" title="Coverstory">Coverstory</a></li>
				<li><a href="/auto-guide/" title="Auto How-to">How-to</a></li>
				<li><a href="/auto-glossary/" title="Automotive Terms Glossary">Glossary</a></li>
				<li><a href="/carfinder/" title="Car Finder">Car finder</a></li>
				<li><a href="/bac/" title="Blood Alcohol Calculator">BAC</a></li>
						</ul>
			<p>
				&copy; 2008-2022 SoftNews Net SRL &bull;
				<a href="/static/privacy.html" title="Privacy Policy">Privacy Policy</a> &bull;
				<a href="/static/cookies.html" title="Cookies Policy">Cookies Policy</a> &bull;
				<a href="/static/terms.html" title="Terms of Use">Terms of Use</a> 
				<br/>All rights reserved. autoevolution&reg; and the autoevolution&reg; logo are registered trademarks.			</p>
		</div>
		<div class="fgoup" onclick="$('html, body').animate({ scrollTop: 0 }, 'slow');"><i class="fa fa-caret-up"></i></div>
	</div>
	<div class="clearfix"></div>
</div>

<script crossorigin type="text/javascript" src="https://s1.cdn.autoevolution.com/_min/?g=js,news,swipebox,jslang_en&amp;v=415"></script>

<script>
window.onload=function() {
	$(window).on("click", aeclosemenus1);
	$("#topmenubtn").on("click", aetopmenu_toggle);
	$("#rtopmenu i.fa").on("click", rmnu_toggle);
};

window.aegal_cty = 'US';
window.aegal_ggon=0;
window.aegal_xdsect='news';
window.ae__nid='205331';

if(typeof aerunstartup=="function") aerunstartup();
aeinputdefaults('input[type="text"]');
</script>

<script>
$(document).ready(function(){
	if(!ae_getcookie('cooknotif2018')) {
		$('body').append('<div id="cookienotif">We use cookies to improve your experience. By using the site you agree to the use of cookies <a class="red" href="javascript:;" onclick="$(\'#cookienotif\').remove();ae_setcookie(\'cooknotif2018\', 1, 365);">Accept &amp; close</a><br/>For more information and options regarding cookies and personal data see our <a href="/static/cookies.html" title="Cookie Policy">Cookies Policy</a> and <a href="/static/privacy.html" title="Privacy Policy">Privacy Policy</a>'+
		'<br/>California residents: <a href="javascript:;" onclick="window.__uspapi(\'displayUspUi\');" title="Do Not Sell My Info" id="CCPA_STATUS">Do Not Sell My Info</a>'+		'</div>');
	}
});
</script>


</body>
</html>