<!DOCTYPE html>
<html lang="en">
<head>
<script>window.aelangvar = 'en';</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function(){
	googletag.pubads().disableInitialLoad();
		window.slot_5f05f46e8ebc8 = googletag.defineSlot("/1004334/AE_news_300x250_ATF_240s_2", [300, 250], "AE_news_300x250_ATF_240s_2__placement_5f05f46e8ebc8__").addService(googletag.pubads()).setTargeting("refresh", "yes");
	window.slot_5f05f46e8ec3b = googletag.defineSlot("/1004334/AE_news_300x250_ATF_240s_2", [300, 250], "AE_news_300x250_ATF_240s_2__placement_5f05f46e8ec3b__").addService(googletag.pubads()).setTargeting("refresh", "yes");
	window.slot_5f05f46e8f110 = googletag.defineSlot("/1004334/AE_news_970x90_240s", [970, 250], "AE_news_970x90_240s__placement_5f05f46e8f110__").addService(googletag.pubads()).setTargeting("refresh", "yes");
		APS_GO();});
</script>

<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
apstag.init({ pubID:  '7db38df2-4062-4df4-9018-dcf399a364c8',  adServer: 'googletag', params:  { us_privacy: "1---" }});
function APS_GO() { apstag.fetchBids({slots: [ { slotName: "/1004334/AE_news_300x250_ATF_240s_2", sizes: [300, 250], slotID: "AE_news_300x250_ATF_240s_2__placement_5f05f46e8ebc8__" }, { slotName: "/1004334/AE_news_300x250_ATF_240s_2", sizes: [300, 250], slotID: "AE_news_300x250_ATF_240s_2__placement_5f05f46e8ec3b__" }, { slotName: "/1004334/AE_news_970x90_240s", sizes: [970, 250], slotID: "AE_news_970x90_240s__placement_5f05f46e8f110__" } ], timeout: 2e3 }, function(bids) { googletag.cmd.push(function(){ console.log('APS_GO: APS'); apstag.setDisplayBids(); googletag.pubads().setCentering(true); googletag.pubads().enableSingleRequest(); googletag.enableServices(); googletag.pubads().refresh(); }); }); }
</script>

<title>Google Working on a Major New Google Maps Feature - autoevolution</title>
<meta name="robots" content="max-snippet:256, max-image-preview:large, max-video-preview: 15" />
<meta name="language" content="en" /><meta http-equiv="content-type" content="text/html; charset=utf-8" /><meta name="viewport" content="width=980" /><meta http-equiv="X-UA-Compatible" content="IE=edge" />
<link rel="preconnnect" href="https://quantcast.mgr.consensu.org" />
<link rel="preconnnect" href="https://vendorlist.consensu.org" />
<link rel="preconnnect" href="https://audit.quantcast.mgr.consensu.org" />
<link rel="preconnnect" href="https://s1.cdn.autoevolution.com/" /><link rel="dns-prefetch" href="https://s1.cdn.autoevolution.com/" />
<link rel="preconnnect" href="https://securepubads.g.doubleclick.net/" />
<link rel="dns-prefetch" href="https://www.google-analytics.com" />
<link rel="dns-prefetch" href="https://c.amazon-adsystem.com" />
<link rel="dns-prefetch" href="https://s.amazon-adsystem.com" />
<link rel="apple-touch-icon" href="/_img/favicon_512.png" /><meta name="msapplication-TileImage" content="/_img/favicon_512.png" /><link rel="mask-icon" sizes="any" href="https://s1.cdn.autoevolution.com/_img/aefavicon.svg" color="#000000" />
<link rel="icon" type="image/x-icon" href="https://s1.cdn.autoevolution.com/_img/favicon.ico?v=2016" /><link rel="shortcut icon" type="image/x-icon" href="https://s1.cdn.autoevolution.com/_img/favicon.ico?v=2016" />
<link rel="alternate" type="application/rss+xml" title="autoevolution news" href="https://www.autoevolution.com/rss/backend.xml">
<link rel="stylesheet" type="text/css" href="https://s1.cdn.autoevolution.com/_min/?g=css&amp;vv=332">
<link rel="canonical" href="https://www.autoevolution.com/news/google-working-on-a-major-new-google-maps-feature-145804.html">
<meta name="description" content="Google Maps continues to be the preferred choice for many users on Android and iPhone, so it makes sense for the search giant to keep working on new features that improve the overall experience for everyone.">
<meta name="keywords" content="Google Maps, Google, Android, iPhone">
<meta property="fb:app_id" content="111790708909959">
<meta property="og:site_name" content="autoevolution">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.autoevolution.com/news/google-working-on-a-major-new-google-maps-feature-145804.html">
<meta property="og:title" content="Google Working on a Major New Google Maps Feature">
<meta property="og:description" content="Google Maps continues to be the preferred choice for many users on Android and iPhone, so it makes sense for the search giant to keep working on new features that improve the overall experience for everyone.">
<meta property="article:publisher" content="https://www.facebook.com/autoevolution">
<meta property="article:published_time" content="2020-07-08T15:11:14+00:00">
<meta property="og:image" content="https://s1.cdn.autoevolution.com/images/news/google-working-on-a-major-new-google-maps-feature-145804-7.jpg">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="@_autoevolution_">
<meta property="twitter:creator" content="@_autoevolution_">
<meta property="twitter:url" content="https://www.autoevolution.com/news/google-working-on-a-major-new-google-maps-feature-145804.html">
<meta property="twitter:title" content="Google Working on a Major New Google Maps Feature">
<meta property="twitter:description" content="Google Maps continues to be the preferred choice for many users on Android and iPhone, so it makes sense for the search giant to keep working on new features that improve the overall experience for everyone.">
<meta property="twitter:image" content="https://s1.cdn.autoevolution.com/images/news/google-working-on-a-major-new-google-maps-feature-145804-7.jpg">
<meta name="author" content="Bogdan Popa">
<script>
window.google_analytics_uacct = "UA-61277-6";
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-61277-6', 'auto'); ga('set', 'anonymizeIp', true);
ga('send', 'pageview');</script>
<script type="text/javascript" src="https://s1.cdn.autoevolution.com/_min/?g=js,jslang_en&amp;vv=356"></script>

<!-- webfontloader -->
<link rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/coresans/coresansn45-webfont.woff2?v=2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/coresans/coresansn65-webfont.woff2?v=2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/coresans/coresansnr47-webfont.woff2?v=2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/coresans/coresansnr57-webfont.woff2?v=2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/coresans/coresansnr67-webfont.woff2?v=2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts/glyphutil/glyphutil_neue-webfont.woff2?v=927" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="https://s1.cdn.autoevolution.com/_css/fonts.css?v=5" as="style">
<script>
	WebFontConfig = {
		classes: false,
		events: false,
		timeout: 2000,
		custom: {
			families: ['CoreSansN:n4,n7', 'CoreSansNRCond:n4,n5,n7', 'Glyphutil Neue'],
			urls: ['https://s1.cdn.autoevolution.com/_css/fonts.css?v=5']
		}
	};

	(function(d) {
		var wf = d.createElement('script'), s = d.scripts[0];
		wf.src = 'https://s1.cdn.autoevolution.com/_js/webfont-1.6.26.js?v=1';
		wf.async = true;
		s.parentNode.insertBefore(wf, s);
	})(document);
</script>
<!-- webfontloader -->

</head>
<body>

<div id="topbar"><div class="container2">

<i class="fa fa-bars" id="topmenubtn"></i>
<a id="autoevolution" href="https://www.autoevolution.com/" title="autoevolution">autoevolution</a>
<div id="topmenu" style="display:none;">
<ul class="m1 clearfix">
	<li><a href="https://www.autoevolution.com/cars/" title="Car models and specifications database">cars</a></li>
	<li><a href="https://www.autoevolution.com/moto/" title="Motorcycle models and specifications database">moto</a></li>
	<li><a href="https://www.autoevolution.com/news/" title="All latest news">news</a></li>
	<li><a href="https://www.autoevolution.com/cars/reviews/?sort=date" title="Car reviews">car reviews</a></li>
	<li><a href="https://www.autoevolution.com/spyshots/" title="Car spyshots and scoops">spyshots</a></li>
	<li><a href="https://www.autoevolution.com/news/driven/" title="Driven cars">driven cars</a></li>
	<li><a href="https://www.autoevolution.com/news/space-junk/" title="Space junk">space junk<!--<span class="black fsz13 line24">new</span>--></a></li>
	<li><a href="https://www.autoevolution.com/green/" title="Green news">green</a></li>
	<li class="newspaper"><a href="https://www.autoevolution.com/newspaper/" title="Newspaper">newspaper <span></span></a></li>
</ul>
<ul class="m2 clearfix">
	<li><a href="https://www.autoevolution.com/carcompare.php" title="Compare cars">Compare Cars <i class="fa fa-car col-red fsz13"></i><i class="fa fa-car col-red fsz13 faded"></i></a></li>
	<li><a href="https://www.autoevolution.com/bac/" title="Blood Alcohol Level Calculator">BAC Calculator &nbsp;<i class="fa fa-flask col-red2"></i></a></li>
	<li><a href="https://www.autoevolution.com/editorial/" title="autoevolution editorials">Editorial</a></li>
	<li><a href="https://www.autoevolution.com/coverstory/" title="autoevolution coverstories">Coverstory</a></li>
	<li><a href="https://www.autoevolution.com/news/motorsport" title="Motorsport news">Motorsport</a></li>
	<li><a href="https://www.autoevolution.com/reviews/" title="Testdrives archive">Testdrives archive</a></li>
	<li><a href="https://www.autoevolution.com/auto-moto-shows/" title="Auto shows coverage index">Auto Shows</a></li>
	<li><a href="https://www.autoevolution.com/news/tuning/" title="Auto tuning news">Tuning</a></li>
	<li><a href="https://www.autoevolution.com/carfinder/" title="Car Finder">Car Finder</a></li>
	<li><a href="https://www.autoevolution.com/newstag/pic%20of%20the%20day/" title="Photo of the Day">Photo of the Day</a></li>
	<li class="long"><a href="https://www.autoevolution.com/auto-glossary/" title="Automotive terms and acronyms database">Glossary of automotive terms</a></li>
	<div class="clearfix"></div>
</ul>
<ul class="m3 clearfix">
	<li><a href="https://www.autoevolution.com/editors/" title="Meet the autoevolution writers and editors">Masthead</a></li>
	<li><a href="https://www.autoevolution.com/rss-channels/" title="Follow autoevolution via RSS">RSS Feeds</a></li>
</ul>
</div>

<div id="topsearch" class="xsgrad1"><form method="get" action="https://www.autoevolution.com/search.php">
<input type="text" name="s" value="Search here..." data-defl="Search here..." /><button type="submit" class="fa fa-search"></button>
</form></div>

<div id="rtopmenu" class="fr">
	<a href="https://www.autoevolution.com/sendtip/" title="Have a news tip? Let us know!"><i class="fa fa-tip col-white"></i></a>
	<i class="fa fa-newspaper rtm-paper col-gold posrel " title="Customize and read your newspaper">
		</i>
	<i class="fa fa-heart rtm-like" title="Follow us on social media"></i>
	<i class="fa fa-info-circle rtm-info" title="Useful information"></i>
</div>

</div></div>
<div class="container2">
	<div id="topwhite" class="h50">
			<div class="eventbar"><a href="https://www.autoevolution.com/newstag/Custom+Builds+Month?utm_source=ae_self&utm_medium=ae_eventline_desktop&utm_campaign=ae_month_twowheeler" title="Custom Builds Month"><b class="faded">FEATURED</b>&nbsp;<img src="https://s1.cdn.autoevolution.com/_img/truck-duotone-inverted.png?v=4" height="16" title="Custom Builds Month" style="vertical-align: initial" />&nbsp; autoevolution's <span data-class="col-gold" style="color:#388df7">Custom Builds Month</span><!-- <b class="col-red">Read all about it</b>--></a></div>
		</div>
</div>

<div id="pagewrapper">

<div class="container2" itemscope itemtype="http://schema.org/NewsArticle">
	
	<div class="col1width col1mg fl">
		<div class="ad300x250 mgtop_10 ad">
		<div id="AE_news_300x250_ATF_240s_2__placement_5f05f46e8ebc8__" style="width:300px; height:250px"></div><script>googletag.cmd.push(function(){ googletag.display("AE_news_300x250_ATF_240s_2__placement_5f05f46e8ebc8__"); setInterval(function(){ googletag.pubads().refresh([window.slot_5f05f46e8ebc8]); }, 240000);  });</script>		</div>


		
				<div id="moreonthis_inner"><div class="moreonthis bulleted mgtop_30"><div class="title titletype1">More on this:</div><a href="https://www.autoevolution.com/news/the-gps-nightmare-on-android-auto-continues-with-no-fix-in-sight-145633.html?utm_source=ae_self&utm_medium=ae_moreon&utm_campaign=ae_moreon_news_static" title="The GPS Nightmare on Android Auto Continues with No Fix in Sight"><img width="90" height="60" title="The GPS Nightmare on Android Auto Continues with No Fix in Sight" alt="The GPS Nightmare on Android Auto Continues with No Fix in Sight" src="https://s1.cdn.autoevolution.com/images/news/the-gps-nightmare-on-android-auto-continues-with-no-fix-in-sight-145633-3.jpg"/><span><b class="black bull">1</b> The GPS Nightmare on Android Auto Continues with No Fix in Sight</span></a><a href="https://www.autoevolution.com/news/google-silently-releases-a-highly-anticipated-waze-feature-for-select-users-145590.html?utm_source=ae_self&utm_medium=ae_moreon&utm_campaign=ae_moreon_news_static" title="Google Silently Releases a Highly Anticipated Waze Feature for Select Users"><img width="90" height="60" title="Google Silently Releases a Highly Anticipated Waze Feature for Select Users" alt="Google Silently Releases a Highly Anticipated Waze Feature for Select Users" src="https://s1.cdn.autoevolution.com/images/news/google-silently-releases-a-highly-anticipated-waze-feature-for-select-users-145590-3.jpg"/><span><b class="black bull">2</b> Google Silently Releases a Highly Anticipated Waze Feature for Select Users</span></a><a href="https://www.autoevolution.com/news/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones-145541.html?utm_source=ae_self&utm_medium=ae_moreon&utm_campaign=ae_moreon_news_static" title="Google Maps Update Brings Surprise Interface Makeover on Android Auto for Phones"><img width="90" height="60" title="Google Maps Update Brings Surprise Interface Makeover on Android Auto for Phones" alt="Google Maps Update Brings Surprise Interface Makeover on Android Auto for Phones" src="https://s1.cdn.autoevolution.com/images/news/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones-145541-3.jpg"/><span><b class="black bull">3</b> Google Maps Update Brings Surprise Interface Makeover on Android Auto for Phones</span></a><a href="https://www.autoevolution.com/news/google-releases-new-google-maps-updates-on-android-and-android-auto-145400.html?utm_source=ae_self&utm_medium=ae_moreon&utm_campaign=ae_moreon_news_static" title="Google Releases New Google Maps Updates on Android and Android Auto"><img width="90" height="60" title="Google Releases New Google Maps Updates on Android and Android Auto" alt="Google Releases New Google Maps Updates on Android and Android Auto" src="https://s1.cdn.autoevolution.com/images/news/google-releases-new-google-maps-updates-on-android-and-android-auto-145400-3.jpg"/><span><b class="black bull">4</b> Google Releases New Google Maps Updates on Android and Android Auto</span></a><a href="https://www.autoevolution.com/news/new-apple-carplay-feature-could-pull-users-away-from-google-maps-145368.html?utm_source=ae_self&utm_medium=ae_moreon&utm_campaign=ae_moreon_news_static" title="New Apple CarPlay Feature Could Pull Users Away from Google Maps"><img width="90" height="60" title="New Apple CarPlay Feature Could Pull Users Away from Google Maps" alt="New Apple CarPlay Feature Could Pull Users Away from Google Maps" src="https://s1.cdn.autoevolution.com/images/news/new-apple-carplay-feature-could-pull-users-away-from-google-maps-145368-3.jpg"/><span><b class="black bull">5</b> New Apple CarPlay Feature Could Pull Users Away from Google Maps</span></a></div></div>
		
				<div id="moreonthis_inner">
			<div class="moreonthis mgtop_20">
				<div class="title titletype1">Car reviews:</div>
				<script src="https://player.anyclip.com/anyclip-widget/lre-widget/prod/v1/src/lre.js" pubname="autoevolutioncom" widgetname="0011r00002IZQzB_1183"></script>
			</div>
		</div>
		
		<div class="ad300x250 mgtop_30"><div id="AE_news_300x250_ATF_240s_2__placement_5f05f46e8ec3b__" style="width:300px; height:250px"></div><script>googletag.cmd.push(function(){ googletag.display("AE_news_300x250_ATF_240s_2__placement_5f05f46e8ec3b__"); setInterval(function(){ googletag.pubads().refresh([window.slot_5f05f46e8ec3b]); }, 240000);  });</script>		</div>

		<div id="moreonthis_inner">
						<div class="moreonthis mgtop_30">
				<div class="title titletype1 upcase"><a href="" title="Up Next">Up Next &nbsp;<i class="fa fa-long-arrow-right"></i></a></div>
				<a href="https://www.autoevolution.com/news/the-carsten-mehring-streetflyer-looks-like-a-torture-device-145760.html?utm_source=ae_self&utm_medium=ae_upnext&utm_campaign=ae_upnext_left">
					<img src="https://s1.cdn.autoevolution.com/images/news/the-carsten-mehring-streetflyer-looks-like-the-fliz-no-relations-145760-3.jpg" width="66" height="40" />
					<span>The Carsten Mehring Streetflyer Looks Like a Torture Device</span>
				</a>
			</div>
					</div>

		&nbsp;
	</div>


<article id="newscol2" class="col2width">
<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.autoevolution.com/news/google-working-on-a-major-new-google-maps-feature-145804.html" />
<meta itemprop="datePublished" content="2020-07-08T15:11:14+0000" />
<meta itemprop="dateModified" content="2020-07-08T15:11:14+0000" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
		<meta itemprop="url" content="https://s1.cdn.autoevolution.com/_img/autoevolution_logo_2016_ldjs.png">
		<meta itemprop="width" content="500">
		<meta itemprop="height" content="100">
	</div>
	<meta itemprop="name" content="Autoevolution">
</div>

<h1 itemprop="headline" class="padcol2 newstitle innews">Google Working on a Major New Google Maps Feature</h1>

<div class="breadcrumb innews">
	<div class="fr">
				8 Jul 2020, 15:11 UTC &middot;
		<div class="col2author">by <a href="https://www.autoevolution.com/editors/browse/bogdan-popa/" title="Check out Bogdan Popa's author profile" itemscope itemtype="http://schema.org/Person" itemprop="author"><b itemprop="name">Bogdan Popa</b></a><img src="https://s1.cdn.autoevolution.com/images/editors/bogdan-popa-64.jpg?v=2019" width="24" height="24" alt="author pic" title="Bogdan Popa" /></div>
	</div>
<span itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><meta itemprop="position" content="1" /><a href="https://www.autoevolution.com/" itemprop="item" title="Home"><span itemprop="name">Home</span></a></span> &gt; <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><meta itemprop="position" content="2" /><a href="https://www.autoevolution.com/news/" itemprop="item" title="News"><span itemprop="name">News</span></a></span> &gt; <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><meta itemprop="position" content="3" /><a href="https://www.autoevolution.com/news/technology/" itemprop="item" title="Technology"><span itemprop="name">Technology</span></a></span></span>	<div class="top2line5"></div>
</div>
<div itemprop="articleBody">
<div class="newssubtext">Google Maps continues to be the preferred choice for many users on Android and iPhone, so it makes sense for the search giant to keep working on new features that improve the overall experience for everyone.</div>
<div class="ch_pic" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><a id="xaegal_0" class="fullimg" href="https://s1.cdn.autoevolution.com/images/news/google-working-on-a-major-new-google-maps-feature-145804_1.jpg" target="_blank"><img itemprop="thumbnailUrl" src="https://s1.cdn.autoevolution.com/images/news-pictures-600x/google-working-on-a-major-new-google-maps-feature-145804-7.jpg" title="Traffic light information on Google Maps" data-gidx="0" data-big="https://s1.cdn.autoevolution.com/images/news/google-working-on-a-major-new-google-maps-feature-145804_1.jpg" data-description="Photo credits: DroidLife" data-title="Traffic light information on Google Maps" /></a><span><em class="fa fa-search-plus"></em> 4 photos</span><meta itemprop="url" content="https://s1.cdn.autoevolution.com/images/news/google-working-on-a-major-new-google-maps-feature-145804_1.jpg"><meta itemprop="width" content="2279"><meta itemprop="height" content="1443"></div><div class="newsgal2 posrel"><div class="vslide" data-count="3"><a id="aegal_0" href="https://s1.cdn.autoevolution.com/images/news/gallery/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones_1.jpg" data-num="0" rel="noopener"><img title="More &quot;#Google Maps&quot; photos (1)" alt="More &quot;#Google Maps&quot; photos (1)" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones-thumbnail_1.jpg" height="78" data-onload="aengal_picloaded('.newsgal',0);" data-gidx="1" data-gidm="809385" data-gida="145804"  data-description="Photo credits: autoevolution" data-title="More &quot;#Google Maps&quot; photos (1)" /></a><a id="aegal_1" href="https://s1.cdn.autoevolution.com/images/news/gallery/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones_2.jpg" data-num="1" rel="noopener"><img title="More &quot;#Google Maps&quot; photos (2)" alt="More &quot;#Google Maps&quot; photos (2)" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones-thumbnail_2.jpg" height="78" data-onload="aengal_picloaded('.newsgal',1);" data-gidx="2" data-gidm="809386" data-gida="145804"  data-description="Photo credits: autoevolution" data-title="More &quot;#Google Maps&quot; photos (2)" /></a><a id="aegal_2" href="https://s1.cdn.autoevolution.com/images/news/gallery/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones_3.jpg" data-num="2" rel="noopener"><img title="More &quot;#Google Maps&quot; photos (3)" alt="More &quot;#Google Maps&quot; photos (3)" src="https://s1.cdn.autoevolution.com/images/news-gallery-130x/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones-thumbnail_3.jpg" height="78" data-onload="aengal_picloaded('.newsgal',2);" data-gidx="3" data-gidm="809387" data-gida="145804"  data-description="Photo credits: autoevolution" data-title="More &quot;#Google Maps&quot; photos (3)" /></a><script type="application/ld+json" id="schema-gallery-data">{"@context":"http:\/\/schema.org","@type":"ImageGallery","url":"https:\/\/www.autoevolution.com\/news\/google-working-on-a-major-new-google-maps-feature-145804.html","associatedMedia":[{"text":"More &quot;#Google Maps&quot; photos (1)","contentUrl":"https:\/\/s1.cdn.autoevolution.com\/images\/news\/gallery\/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones_1.jpg","thumbnailUrl":"https:\/\/s1.cdn.autoevolution.com\/images\/news-gallery-130x\/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones-thumbnail_1.jpg"},{"text":"More &quot;#Google Maps&quot; photos (2)","contentUrl":"https:\/\/s1.cdn.autoevolution.com\/images\/news\/gallery\/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones_2.jpg","thumbnailUrl":"https:\/\/s1.cdn.autoevolution.com\/images\/news-gallery-130x\/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones-thumbnail_2.jpg"},{"text":"More &quot;#Google Maps&quot; photos (3)","contentUrl":"https:\/\/s1.cdn.autoevolution.com\/images\/news\/gallery\/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones_3.jpg","thumbnailUrl":"https:\/\/s1.cdn.autoevolution.com\/images\/news-gallery-130x\/google-maps-update-brings-surprise-interface-makeover-on-android-auto-for-phones-thumbnail_3.jpg"}]}</script></div><div class="dotbox curpo" onclick="return open_lght(0)"></div></div><div class="newstext innews">
<div class="mgtop_20">
Most recently, the company has started the work on a new feature for Google Maps that brings traffic light information both when navigating and when exploring a specific location.<br />
<br />
For the time being, this is a very limited test, so the feature only shows up for a small number of users on Android devices. Of course, once the traffic light data is reliable enough, it&rsquo;s likely to go live for iPhone users too.<br />
<br />
According to a recent report from <a rel="noopener" target="_blank" href="https://www.droid-life.com/2020/07/07/google-maps-is-starting-to-show-traffic-lights-on-android/">DroidLife</a>, the traffic lights are displayed on the map using a dedicated icon, and judging from screenshots that were posted online, these are just small indicators that are rather difficult to notice. At this point, however, it&rsquo;s not known if Google wants to also add notifications for traffic lights when the navigating mode is activated.<br />
<br />
Traffic light information is one of the features that Apple has already announced as part of a major Apple Maps update released earlier this year. However, this feature is only available for users in the United States, and there&rsquo;s a chance that the same thing would happen with this Google Maps update as well.<br />
<br />
Most likely, traffic light information will also go live for users running Google Maps on Android Auto and CarPlay, so they will be shown on bigger screens when smartphones are connected to head units installed in cars. An ETA, however, isn&rsquo;t yet available at this point.<br />
<br />
Google has remained completely tight-lipped on this new feature, but it&rsquo;s something that makes perfect sense, especially since Apple has also added similar functionality to Apple Maps. When exactly the feature is supposed to go live for everyone, however, is something that is yet to be determined.<div class="clearfix"></div></div><div class="mgtop_20"><i class="fa fa-flag-checkered ico col-red3"></i></div></div>



	<div class="clearfix"></div>
</div>
<div class="posrel"></div><!-- posrel -->
<div class="filedunder mgtop_20"><a href="https://www.autoevolution.com/newstag/Google%20Maps/" title="More stories about &quot;Google Maps&quot;" class="newstag">Google Maps</a> <a href="https://www.autoevolution.com/newstag/Google/" title="More stories about &quot;Google&quot;" class="newstag">Google</a> <a href="https://www.autoevolution.com/newstag/Android/" title="More stories about &quot;Android&quot;" class="newstag">Android</a> <a href="https://www.autoevolution.com/newstag/iPhone/" title="More stories about &quot;iPhone&quot;" class="newstag">iPhone</a> </div>
<div class="clearfix"></div>
<div id="disqus_thread" class="bgwhite overauto"><button onclick="$('#disqus_thread').toggleClass('padcol2'); loadDisqus()" type="button" class="ulbtn dispblock posrel zx1"><i class="fa fa-comment col-red"></i>click to load Disqus comments for this story</span><span class="disclaim">This enables Disqus, Inc. to process some of your data.</span></button></div>
<script>var disqus_config = function () { this.page.url = 'https://www.autoevolution.com/news/google-working-on-a-major-new-google-maps-feature-145804.html'; this.page.identifier = 'dsq_ae_news_145804'; };</script>
<div class="clearfix"></div>



</article><!-- midcol -->

<div id="newscol3" class="col3width overhide">
<div class="moreonthis mgleft_20 mgtop_10 vehicles"><div class="title titletype1">Latest car models:</div><a href="https://www.autoevolution.com/cars/porsche-928-s-1980.html" title="PORSCHE 928 S"><img width="90" height="60" title="PORSCHE 928 S" alt="PORSCHE 928 S" src="https://s1.cdn.autoevolution.com/images/models/thumb/PORSCHE_928-S-1980_main.jpg_tmb.jpg"/><span>PORSCHE 928 S <span>Coupe</span></span></a><a href="https://www.autoevolution.com/cars/porsche-911-turbo-s-992-2020.html" title="PORSCHE 911 Turbo S (992)"><img width="90" height="60" title="PORSCHE 911 Turbo S (992)" alt="PORSCHE 911 Turbo S (992)" src="https://s1.cdn.autoevolution.com/images/models/thumb/PORSCHE_911-Turbo-S--992--2020_main.jpg_tmb.jpg"/><span>PORSCHE 911 Turbo S (992) <span>Coupe</span></span></a><a href="https://www.autoevolution.com/cars/volkswagen-nivus-2020.html" title="VOLKSWAGEN Nivus"><img width="90" height="60" title="VOLKSWAGEN Nivus" alt="VOLKSWAGEN Nivus" src="https://s1.cdn.autoevolution.com/images/models/thumb/VOLKSWAGEN_Nivus--2020_main.jpg_tmb.jpg"/><span>VOLKSWAGEN Nivus <span>Small SUV</span></span></a><a href="https://www.autoevolution.com/cars/toyota-hilux-double-cab-2020.html" title="TOYOTA Hilux Double Cab"><img width="90" height="60" title="TOYOTA Hilux Double Cab" alt="TOYOTA Hilux Double Cab" src="https://s1.cdn.autoevolution.com/images/models/thumb/TOYOTA_Hilux-Double-Cab-2020_main.jpg_tmb.jpg"/><span>TOYOTA Hilux Double Cab <span>Midsize Pickup</span></span></a><a href="https://www.autoevolution.com/cars/mazda-2-2019.html" title="MAZDA 2"><img width="90" height="60" title="MAZDA 2" alt="MAZDA 2" src="https://s1.cdn.autoevolution.com/images/models/thumb/MAZDA_2-2019_main.jpg_tmb.jpg"/><span>MAZDA 2 <span>Small</span></span></a><a href="https://www.autoevolution.com/cars/audi-rs4-avant-b10-2019.html" title="AUDI RS4 Avant (B10)"><img width="90" height="60" title="AUDI RS4 Avant (B10)" alt="AUDI RS4 Avant (B10)" src="https://s1.cdn.autoevolution.com/images/models/thumb/AUDI_RS4-Avant--B10--2019_main.jpg_tmb.jpg"/><span>AUDI RS4 Avant (B10) <span>Compact</span></span></a><a href="https://www.autoevolution.com/cars/mercedes-benz-e-class-t-modell-all-terrain-s213-2020.html" title="MERCEDES BENZ E-Class T-Modell All Terrain (S213)"><img width="90" height="60" title="MERCEDES BENZ E-Class T-Modell All Terrain (S213)" alt="MERCEDES BENZ E-Class T-Modell All Terrain (S213)" src="https://s1.cdn.autoevolution.com/images/models/thumb/MERCEDES-BENZ_E-Class-T-Modell-All-Terrain--S213--2020_main.jpg_tmb.jpg"/><span>MERCEDES BENZ E-Class T-Modell All Terrain (S213) <span>Medium</span></span></a><a href="https://www.autoevolution.com/cars/bmw-5-series-touring-2020.html" title="BMW 5 Series Touring"><img width="90" height="60" title="BMW 5 Series Touring" alt="BMW 5 Series Touring" src="https://s1.cdn.autoevolution.com/images/models/thumb/BMW_5-Series-Touring--2020_main.jpg_tmb.jpg"/><span>BMW 5 Series Touring <span>Large</span></span></a><a href="https://www.autoevolution.com/cars/mercedes-amg-e-63-amg-estate-s214-2020.html" title="Mercedes-AMG E 63 AMG Estate (S214)"><img width="90" height="60" title="Mercedes-AMG E 63 AMG Estate (S214)" alt="Mercedes-AMG E 63 AMG Estate (S214)" src="https://s1.cdn.autoevolution.com/images/models/thumb/Mercedes-AMG_E-63-AMG-Estate--S214--2020_main.jpg_tmb.jpg"/><span>Mercedes-AMG E 63 AMG Estate (S214) <span>Luxury</span></span></a><a href="https://www.autoevolution.com/cars/morgan-plus-four-2020.html" title="MORGAN Plus Four"><img width="90" height="60" title="MORGAN Plus Four" alt="MORGAN Plus Four" src="https://s1.cdn.autoevolution.com/images/models/thumb/MORGAN_Plus-Four-2020_main.jpg_tmb.jpg"/><span>MORGAN Plus Four <span>Roadster &amp; Convertible</span></span></a><a href="https://www.autoevolution.com/cars/" title="Full list of car models and specifications" class="bold upcase seeall">All car models &nbsp;<i class="fa fa-long-arrow-right"></i></a></div>
		<div class="mgleft_20 mgtop_20">
		<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
		<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2364887827571271" data-ad-slot="9053923839" data-ad-format="link" data-full-width-responsive="true"></ins>
		<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
	</div>
	
	
</div><!-- newscol3 -->

<div class="clearfix"></div>

<div class="col123width bgcutgrad">
	<div class="ad970x250 ad ad_adc" style="background-color: #e4e4e4; text-align: center;">
	<div id="AE_news_970x90_240s__placement_5f05f46e8f110__" style="width:970px; height:250px"></div><script>googletag.cmd.push(function(){ googletag.display("AE_news_970x90_240s__placement_5f05f46e8f110__"); setInterval(function(){ googletag.pubads().refresh([window.slot_5f05f46e8f110]); }, 240000);  });</script>	</div>
</div>

<div class="fl" id="newscol1">
	<div id="morepopular1">&nbsp;</div>
	<div id="morescrollad1">&nbsp;</div>
	<div id="morepopular2">&nbsp;</div>
</div>
<div class="col2width fl bgcutgrad" id="morescroll">&nbsp;</div>

<div class="col3width fl">
	<div id="more_X">&nbsp;</div>
	<div id="morelinks">&nbsp;</div>
</div>

<div class="clearfix"></div>
<div class="col123width bgcutgrad"><div id="morescrollad2"></div><br/></div>

</div><!-- container -->

<iframe class="artr" src="https://www.autoevolution.com/rhh.php?k=artr&art=145804&se=news" width="0" height="0"><noframes><img src="https://www.autoevolution.com/rhh.php?k=artr&art=145804&se=news" width="1" height="1" /></noframes></iframe>

<script>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</script>

<div id="notif_asker_div">
	<div id="notif_asker_buttons">
		<h4>Would you like <span class="col-red">AUTOEVOLUTION</span> to send you notifications?</h4>
		<p>You will only receive our top stories,<br/>typically no more than 5 per day</p>
		<div id="notif_asker_btns">
			<button type="button" class="notif_btn blk" onclick="notif_continue(true)" title="Please click ALLOW when prompted">yes</button>
			<button type="button" class="notif_btn" onclick="notif_continue(false)">no</button>
		</div>
	</div>
</div>

<script>
function notif_asker() {
	$('body,html').css('overflow', 'hidden');
	$('#notif_asker_div').show();
}

function notif_continue(go) {
	if(go === true) {
		ae_setcookie('notif_dontask', 'dont', 60);

		$('#notif_asker_buttons').html('<h4 class="mgbot_20"><span class="col-red">Thank you!</span><br/>Please click ALLOW when prompted</h4>');
		setTimeout(function() {
			$('#notif_asker_div').remove();
			$('body,html').css('overflow', 'visible');
		}, 3000);

		var d = document, s = d.createElement('script');
		s.src = 'https://www.autoevolution.com/notificator.js?v=127';
		s.setAttribute('id', 'notif_asker_js');
		(d.head || d.body).appendChild(s);
		window.askOnLoad = 1;
	}
	else {
		ae_setcookie('notif_dontask', 'dont', 60);
		$('#notif_asker_div').remove();
		$('body,html').css('overflow', 'visible');
	}
}
</script>

<div class="clearfix"></div>
</div><!-- pagewrapper -->

<div id="footer">
	<div class="container">
		<div id="footcol1">
			<a href="/rss-channels/" class="fa fa-rss fl col-red"></a>
			<a href="https://www.autoevolution.com/" id="footauto" title="autoevolution">autoevolution</a>
			<span id="footprivacyl">
				<a href="/contact/" title="Contact Us">Contact Us</a> &bull;
				<a href="/static/privacy.html" title="Privacy Policy">Privacy Policy</a> &bull;
				<a href="/static/cookies.html" title="Cookies Policy">Cookies Policy</a>
				<br/>
							</span>
		</div>
		<div id="footcol2">
			<ul>
							<li><a href="/cars/" title="Cars">Cars</a></li>
				<li><a href="/moto/" title="Moto">Moto</a></li>
				<li><a href="/news/" title="News">News</a></li>
				<li><a href="/cars/reviews/" title="Car Reviews">Reviews</a></li>
				<li><a href="/editorial/" title="Editorials">Editorials</a></li>
				<li><a href="/coverstory/" title="Coverstory">Coverstory</a></li>
				<li><a href="/auto-guide/" title="Auto How-to">How-to</a></li>
				<li><a href="/auto-glossary/" title="Automotive Terms Glossary">Glossary</a></li>
				<li><a href="/carfinder/" title="Car Finder">Car finder</a></li>
				<li><a href="/bac/" title="Blood Alcohol Calculator">BAC</a></li>
						</ul>
			<p>&copy; 2008-2020 SoftNews Net SRL.<br/>All rights reserved. autoevolution&reg; and the autoevolution&reg; logo are registered trademarks.</p>
		</div>
		<div class="fgoup" onclick="$('html, body').animate({ scrollTop: 0 }, 'slow');"><i class="fa fa-caret-up"></i></div>
	</div>
	<div class="clearfix"></div>
</div>

<script type="application/ld+json">
{
	"@context": "http://schema.org", "@type": "Organization", "url": "https://www.autoevolution.com/", "logo": "https://www.autoevolution.com/_img/autoevolution_logo_2016_ldjs.png", "name": "autoevolution",  "sameAs" : [
		"https://www.facebook.com/autoevolution",
		"https://twitter.com/_autoevolution_",
		"https://flipboard.com/@autoevolution/autoevolution-e4m5gpaay"
	]
}
</script>
<script type="application/ld+json">{ "@context": "http://schema.org", "@type": "WebSite", "name": "autoevolution", "url": "https://www.autoevolution.com/" }</script>

<script type="text/javascript" src="https://s1.cdn.autoevolution.com/_min/?g=news,swipebox&amp;vv=356"></script>
<script>

window.onload=function() {
	$(window).on("click", aeclosemenus1);
	$("#topmenubtn").on("click", aetopmenu_toggle);
	$("#rtopmenu i.fa").on("click", rmnu_toggle);
};

window.aegal_cty = 'US';
window.aegal_ggon=0;
window.aegal_xdsect='news';
window.ae__nid='145804';

if(typeof aerunstartup=="function") aerunstartup();
aeinputdefaults('input[type="text"]');
</script>

<script>
$(document).ready(function(){
	if(!ae_getcookie('cooknotif2018')) {
		$('body').append('<div id="cookienotif">We use cookies to improve your experience. By using the site you agree to the use of cookies <a class="red" href="javascript:;" onclick="$(\'#cookienotif\').remove();ae_setcookie(\'cooknotif2018\', 1, 365);">Accept &amp; close</a><br/>For more information and options regarding cookies and personal data see our <a href="/static/cookies.html" title="Cookie Policy">Cookies Policy</a> and <a href="/static/privacy.html" title="Privacy Policy">Privacy Policy</a></div>');
	}
});
</script>

</body>
</html>